You are here

Opti-myst troubleshooter

Please check the following before trying resolve any problems you may be having with your Opti-myst fire: 

The lead and plug are firmly connected to the kettle lead connection at the rear of the fire

The plug is firmly inserted into the wall socket

You have tried another appliance in the socket to confirm supply

You have double checked to ensure the fire is switched on

What is the problem with your Opti-myst fire?

Too much mist is being produced

-First, adjust the mist effect down on the fire.

 

-If the problem continues, this may be an issue with the mist control and should be rectified by a service engineer. Please fill out our service call request form at the bottom of this page.

 

Not enough mist is being produced

-Check that the sump is full but not overfilled, and that the filler cap to the water tank is screwed on firmly to ensure water is not seeping into the sump and causing it to overfill.

 

-Secondly, ensure the black lead from the transducer is not crossing the top of the transducer disc, this will minimise or completely stop the formation of mist.

 

-Check the mist nozzle (the orange component sat on top of the sump). Ensure it is clean and clear of deposits and that there are no obstructions.

 

-Finally, check that all the lamps are working and replace any that are not. These are available from the spares section of our website.

 

-If none of these steps resolve the issue, then please fill out the service call request form at the bottom of this page.

 

The remote for my Opti-myst is faulty

- Ensure new or fully charged rechargeable batteries are correctly inserted and are correctly orientated.

 

-Ensure that the remote is being used within the parameters stated in the user instructions. The signal is directive, so the remote control must be pointed towards the fire.

 

-Ensure the small infrared receiver lens is clean – this is located within the fret on the right hand side in Inset fires, and top right hand side of the controls on modules and stoves.

 

-If none of these steps resolve the issue, then please fill out the service call request form at the bottom of this page.

 

The lights are not coming on when I turn on my Opti-myst

-If one of the lamps supplied with the fire is not working check that it is fitted correctly. If it still does not work then the lamp may have failed. These are available from the spares section of our website and should be replaced immediately.

 

-If all lights are not coming on, first, check that the lamps supplied with the fire are fitted correctly.

 

-If the lamps are correctly fitted, then ensure that the transducer is properly located in the sump and is plugged in. Confirm that there is sufficient water in the sump to cover the transducer.

 

-If these steps do not resolve the issue, then please fill out the service call request form at the bottom of this page.

 

No mist is being produced when I turn on my Opti-myst

-Firstly, check that the water tank has sufficient water so that the sump can be filled and covers the transducer.

 

-Ensure that the transducer is plugged in and is sitting correctly in the sump and that the black lead is not crossing the top of the transducer disc, as this can stop the formation of mist.

 

-If the above steps haven not fixed the issue, it could indicate that the sump fan has failed. To confirm it is working correctly, remove the water tank and mist nozzle, and then gently insert the small cleaning brush (supplied with your Opti-myst) into the air outlet from the fan housing located on the top right hand side of the sump. If the fan is working, a sound will be heard and a vibration felt.

 

-Finally, check that all four lamps are fitted and working.

 

-If none of these steps resolve the issue, then please fill out the service call request form at the bottom of this page.

 

No heat is being produced from my Opti-myst

-Please check that the thermostat is set above the ambient room temperature. This can be checked by turning the thermostat to maximum and then regulated until the comfort level is established.

 

-If the fire is located in an existing fireplace, check that the chimney is fully blocked. Down draft from the chimney may disturb the airflow of the element, causing the overheat cut-out to operate.

 

-If none of these steps resolve the issue, then please fill out the service call request form at the bottom of this page.

 

The mist cuts out after 30 seconds

-Please check that the transducer is plugged in correctly and is seated correctly in the sump. Ensure that the black transducer lead is not covering the white disc, as this will stop the formation of the mist.

 

-A regular cleaning regime should be followed and any calcium deposits should be removed from the transducer using the cleaning brush provided.

 

-If none of these steps resolve the issue, then please fill out the service call request form at the bottom of this page.

 

The mist cuts out intermittently

-Firstly, please check that there is sufficient water in the sump and that the sump fan is turning freely.

 

-Check that the transducer is seated correctly in the sump and that the fan filter is positioned correctly.

 

-If none of these steps resolve the issue, then please fill out the service call request form at the bottom of this page.